<!-- 
                             Deployment Date: 01 Sep 2022, 10:34:11 am                                                             
                                                                                         
   _____ _____ _____ _____ _____ _____ _____ _____ _____ _____ _____ _____ _____ _____   
  |_____|_____|_____|_____|_____|_____|_____|_____|_____|_____|_____|_____|_____|_____|  
    ____            _       _   _         _                                              
   |  _ \   _   _  | |__   | | (_)  ___  | |__    _ __   _ __        ___ ___  _ __ ___   
   | |_) | | | | | | '_ \  | | | | / __| | '_ \  | '__| | '__|      / __/ _ \| '_ ` _ \  
   |  __/  | |_| | | |_) | | | | | \__ \ | | | | | |    | |     _  | (_| (_) | | | | | | 
   |_|      \__,_| |_.__/  |_| |_| |___/ |_| |_| |_|    |_|    (_)  \___\___/|_| |_| |_| 
   _____ _____ _____ _____ _____ _____ _____ _____ _____ _____ _____ _____ _____ _____   
  |_____|_____|_____|_____|_____|_____|_____|_____|_____|_____|_____|_____|_____|_____|   



-->

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> <html xmlns="http://www.w3.org/1999/xhtml" class=" js no-touch svg inlinesvg svgclippaths no-ie8compat js no-touch svg inlinesvg svgclippaths no-ie8compat" lang="en"> <head> <meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> <title>‘Star Wars’ writer wants to follow Marvel model for franchise</title> <meta name="description" content="NEW YORK-Star Wars writer Jonathan Kasdan wants to replicate the Marvel model to tell stories in the franchise after being inspired by Marvel&rsquo;s recent Werewolf by" /> <meta name="keywords" content="star wars, writer, follow" /> <meta name="news_keywords" content="star wars, writer, follow" /> <meta property="article:tag" content="star wars, writer, follow" /> <meta property="og:type" content="article" /> <meta name="twitter:card" content="summary_large_image"> <meta property="og:site_name" content="The Nation"/> <meta property="og:title" content="‘Star Wars’ writer wants to follow Marvel model for franchise" /> <meta name="twitter:title" content="‘Star Wars’ writer wants to follow Marvel model for franchise"> <meta itemprop="name" content="‘Star Wars’ writer wants to follow Marvel model for franchise"> <meta property="og:description" content="NEW YORK-Star Wars writer Jonathan Kasdan wants to replicate the Marvel model to tell stories in the franchise after being inspired by Marvel&rsquo;s recent" /> <meta itemprop="description" content="NEW YORK-Star Wars writer Jonathan Kasdan wants to replicate the Marvel model to tell stories in the franchise after being inspired by Marvel&rsquo;s recent"> <meta name="twitter:description" content="NEW YORK-Star Wars writer Jonathan Kasdan wants to replicate the Marvel model to tell stories in the franchise after being inspired by Marvel&rsquo;s recent"> <meta property="og:url" content="https://www.nation.com.pk/05-Dec-2022/star-wars-writer-wants-to-follow-marvel-model-for-franchise" /> <meta name="twitter:url" content="https://www.nation.com.pk/05-Dec-2022/star-wars-writer-wants-to-follow-marvel-model-for-franchise"> <meta property="og:small_image" content="https://www.nation.com.pk/print_images/small/2022-12-05/star-wars-writer-wants-to-follow-marvel-model-for-franchise-1670188653-6064.jpg" /> <meta property="og:image" content="https://www.nation.com.pk/print_images/large/2022-12-05/star-wars-writer-wants-to-follow-marvel-model-for-franchise-1670188653-6064.jpg" /> <meta property="og:image:width" content="800"> <meta property="og:image:height" content="600"> <meta itemprop="image" content="https://www.nation.com.pk/print_images/large/2022-12-05/star-wars-writer-wants-to-follow-marvel-model-for-franchise-1670188653-6064.jpg"> <meta name="twitter:image" content="https://www.nation.com.pk/print_images/large/2022-12-05/star-wars-writer-wants-to-follow-marvel-model-for-franchise-1670188653-6064.jpg"> <meta name="viewport" content="width=device-width, initial-scale=1.0"> <meta name="generator" content="Publishrr.com" /> <link rel="preconnect" href="https://www.googletagmanager.com"><link rel="preconnect" href="https://adservice.google.com"><link rel="preconnect" href="https://googleads4.g.doubleclick.net"><link rel="preconnect" href="https://googleads.g.doubleclick.net"><link rel="preconnect" href="https://adservice.google.com.pk"><link rel="preconnect" href="https://pagead2.googlesyndication.com"><link rel="preconnect" href="https://securepubads.g.doubleclick.net"><link rel="preconnect" href="https://www.googletagservices.com"><link rel="preconnect" href="https://bid.g.doubleclick.net"><link rel="preconnect" href="https://pubads.g.doubleclick.net"><link rel="preconnect" href="https://www.gstatic.com"><link rel="preconnect" href="https://tpc.googlesyndication.com"><link rel="preconnect" href="https://www.google-analytics.com"><link rel="preconnect" href="https://www.google.com"><link rel="preconnect" href="https://cdn.ampproject.org"><link rel="preconnect" href="https://fonts.googleapis.com"><link rel="preconnect" href="https://imasdk.googleapis.com"><link rel="preconnect" href="https://www.facebook.com"><link rel="preconnect" href="https://static.xx.fbcdn.net"><link rel="preconnect" href="https://connect.facebook.net"><link rel="preconnect" href="https://maxcdn.bootstrapcdn.com"><link rel="preconnect" href="https://i.ytimg.com"> <link rel="apple-touch-icon" sizes="180x180" href="https://www.nation.com.pk/assets/thenation/images/favicons/apple-touch-icon.png"> <link rel="icon" type="image/png" sizes="32x32" href="https://www.nation.com.pk/assets/thenation/images/favicons/favicon-32x32.png"> <link rel="icon" type="image/png" sizes="16x16" href="https://www.nation.com.pk/assets/thenation/images/favicons/favicon-16x16.png"> <link rel="manifest" href="https://www.nation.com.pk/assets/thenation/images/favicons/site.webmanifest"><meta name="msapplication-TileColor" content="#ffffff"> <meta name="msapplication-TileImage" content="https://www.nation.com.pk/assets/thenation/images/favicons/mstile-144x144.png"> <meta property="og:locale" content="en_US" /> <link rel="alternate" type="application/rss+xml" title="The Nation" href="https://www.nation.com.pk/rss" /> <link rel="alternate" type="application/rss+xml" title="The Nation" href="https://www.nation.com.pk/sitemap.xml" /> <meta property="article:published_time" content="2022-12-05T02:17:44+05:00" /> <meta property="article:section" content="Lifestyle & Entertainment" /> <link rel="amphtml" href="https://www.nation.com.pk/05-Dec-2022/star-wars-writer-wants-to-follow-marvel-model-for-franchise?version=amp" /> <script> function FB_post_feed() { var url=FB.ui({ method: 'share', iframe_test: true, href: 'https://www.nation.com.pk/05-Dec-2022/star-wars-writer-wants-to-follow-marvel-model-for-franchise', }, function(response) {}); } </script> <link rel="stylesheet" href="https://www.nation.com.pk/assets/thenation/css/style.css?mdate=1662010451" /> <link rel="stylesheet" href="https://www.nation.com.pk/assets/thenation/css/custom.css?mdate=1662010451" /> <link rel="stylesheet" href="https://www.nation.com.pk/assets/thenation/css/home_page.css?mdate=1662010451" /> <link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700&ver=3.8.3?mdate=1662010451" /> <link rel="stylesheet" href="https://www.nation.com.pk/assets/thenation/css/javascript_calender.css?mdate=1662010451" /> <link rel="stylesheet" href="https://www.nation.com.pk/assets/thenation/css/epaper_page.css?mdate=1662010451" /> <link rel="stylesheet" href="https://www.nation.com.pk/assets/thenation/css/owl.carousel.min.css?mdate=1662010451" /> <link rel="stylesheet" href="https://www.nation.com.pk/assets/thenation/css/owl.carousel.css?mdate=1662010451" /> <link rel="stylesheet" href="https://www.nation.com.pk/assets/thenation/css/owl.theme.default.min.css?mdate=1662010451" /> <link rel="stylesheet" href="https://www.nation.com.pk/assets/thenation/css/lightslider.css?mdate=1662010451" /> <link rel="stylesheet" href="https://www.nation.com.pk/assets/thenation/css/colorbox.css?mdate=1662010451" /> <style> .ad_code_class iframe { }</style><script> var asset_dir = "https://www.nation.com.pk/assets/thenation/"; var templateDir = "https://www.nation.com.pk/"; var current_page_link = "www.nation.com.pk/05-Dec-2022/star-wars-writer-wants-to-follow-marvel-model-for-franchise"; var category_page_slug = ""; var cms_page_slug = ""; var news_categories = "lifestyle-entertainment"; var news_tags = "star wars, writer, follow"; </script> <script async src="https://www.googletagmanager.com/gtag/js?id=G-LB5432WXV3"></script> <script> window.dataLayer = window.dataLayer || []; function gtag(){dataLayer.push(arguments);} gtag('js', new Date()); gtag('config', 'G-LB5432WXV3'); </script> <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script> <script> window.googletag = window.googletag || {cmd: []}; googletag.cmd.push(function() { var mapping = googletag.sizeMapping().addSize([800, 0], [[970, 90], [728, 90]]).addSize([0, 0], [[320, 100], [300, 100]]).build(); googletag.defineSlot('/1002138/NATN_AP_Ad_Unit_1', [[728, 90], [320, 100], [970, 90], [300, 100]], 'div-gpt-ad-1664962363141-0').defineSizeMapping(mapping).addService(googletag.pubads()); googletag.pubads().enableSingleRequest(); googletag.pubads().collapseEmptyDivs(); googletag.enableServices(); }); </script> <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script> <script> window.googletag = window.googletag || {cmd: []}; googletag.cmd.push(function() { var mapping = googletag.sizeMapping().addSize([800, 0], [300, 600]).addSize([0, 0], [300, 600]).build(); googletag.defineSlot('/1002138/NATN_CP-DP_AD_UNIT_1', [300, 600], 'div-gpt-ad-1665042098634-0').defineSizeMapping(mapping).addService(googletag.pubads()); googletag.pubads().enableSingleRequest(); googletag.pubads().collapseEmptyDivs(); googletag.enableServices(); }); </script> <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script> <script> window.googletag = window.googletag || {cmd: []}; googletag.cmd.push(function() { var mapping = googletag.sizeMapping().addSize([800, 0], [728, 90]).addSize([0, 0], [[320, 100], [300, 100]]).build(); googletag.defineSlot('/1002138/NATN_DP_Ad_Unit_1', [[320, 100], [300, 100], [728, 90]], 'div-gpt-ad-1665039207874-0').defineSizeMapping(mapping).addService(googletag.pubads()); googletag.pubads().enableSingleRequest(); googletag.pubads().collapseEmptyDivs(); googletag.enableServices(); }); </script> <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script> <script> window.googletag = window.googletag || {cmd: []}; googletag.cmd.push(function() { var mapping = googletag.sizeMapping().addSize([800, 0], [728, 90]).addSize([0, 0], [[320, 100], [300, 100]]).build(); googletag.defineSlot('/1002138/NATN_DP_Ad_Unit_2', [[728, 90], [300, 100], [320, 100]], 'div-gpt-ad-1665039486075-0').defineSizeMapping(mapping).addService(googletag.pubads()); googletag.pubads().enableSingleRequest(); googletag.pubads().collapseEmptyDivs(); googletag.enableServices(); }); </script> <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script> <script> window.googletag = window.googletag || {cmd: []}; googletag.cmd.push(function() { var mapping = googletag.sizeMapping().addSize([800, 0], [300, 250]).addSize([0, 0], [300, 250]).build(); googletag.defineSlot('/1002138/NATN_AP_Ad_Unit_2', [300, 250], 'div-gpt-ad-1664962020792-0').defineSizeMapping(mapping).addService(googletag.pubads()); googletag.pubads().enableSingleRequest(); googletag.pubads().collapseEmptyDivs(); googletag.enableServices(); }); </script> <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script> <script> window.googletag = window.googletag || {cmd: []}; googletag.cmd.push(function() { var mapping = googletag.sizeMapping().addSize([800, 0], [300, 600]).addSize([0, 0], [300, 600]).build(); googletag.defineSlot('/1002138/NATN_AP_Ad_Unit_3', [300, 600], 'div-gpt-ad-1664963951820-0').defineSizeMapping(mapping).addService(googletag.pubads()); googletag.pubads().enableSingleRequest(); googletag.pubads().collapseEmptyDivs(); googletag.enableServices(); }); </script> <script type="text/javascript"> function block_load_more( load_more_button_id, block_slug ) { var block_offset = parseInt($('#'+block_slug+'_offset_count' ).val()); var myElem = document.getElementById( block_slug+'-load-more' ); if (myElem === null) { alert('Please specify "" div container with id "#'+block_slug+'-load-more" '); return false; } $('#post_load_loader').css('display','block'); $('#'+block_slug+'_load_more_btn' ).hide(); $.ajax({ method: "POST", url: "https://www.nation.com.pk/ajax_block_pagination", data: { block_slug: block_slug, block_offset: block_offset, news_date: '1670180400', category_slug: '', }, beforeSend: function( xhr ) { } }) .done(function( data ) { $('#post_load_loader').css('display','none'); $('#'+block_slug+'_load_more_btn' ).show(); if ( data == 'no_more_news' ) { $('#'+load_more_button_id).css({display:none}); } else { $( '#'+block_slug+'-load-more' ).append(data); } }); } </script> <style> @media(min-width: 768px){ .oembed_ltr{ border: 1px solid #e0e0e0!important;width: 90%;padding: 5px!important;display: block;margin: 0 auto; margin-top: 20px; margin-bottom: 20px; width: 100%; } .oembed_image{ width: 70px;float:left;margin-right: 10px; } .oembed_image .top-center { background-size: 100%; } .oembed_title{ min-height:55px;display: flex;align-items: center; } } .oembed_title a { font-size: 16px; line-height: 24px; color:#222; overflow: hidden;text-align: left;margin: 0px!important; } @media(max-width: 768px){ .oembed_ltr{ width: 100%;padding: 5px!important;display: inline-block;border: 1px solid #e0e0e0!important; } .oembed_image{ width: 75px;float:left;margin-right: 10px; } .oembed_title{ display: flex;align-items: center; } } </style> <script type="application/ld+json"> { "@context": "http://schema.org", "@type": "NewsArticle", "mainEntityOfPage": { "@type": "WebPage", "@id": "https://www.nation.com.pk/05-Dec-2022/star-wars-writer-wants-to-follow-marvel-model-for-franchise" }, "headline": "‘Star Wars’ writer wants to follow Marvel model for franchise", "image": [ "https://www.nation.com.pk/print_images/extra-large/2022-12-05/star-wars-writer-wants-to-follow-marvel-model-for-franchise-1670188653-6064.jpg" ], "datePublished": "2022-12-05T02:17:44+05:00", "dateModified": "2022-12-05T02:17:44+05:00", "author": { "@type": "Person", "name": "News Desk" }, "publisher": { "@type": "Organization", "name": "The Nation", "logo": { "@type": "ImageObject", "url": "https://www.nation.com.pk/uploads/theme/logo-1550475639.png" } }, "description": "NEW YORK-Star Wars writer Jonathan Kasdan wants to replicate the Marvel model to tell stories in the franchise after being inspired by Marvel&rsquo;s recent Werewolf by Night show. During an interview with The Hollywood Reporter, Kasdan said, &ldquo;In recent months, I have been intrigued by the wonderful Werewolf by Night as a potential form of storytelling on Disney+,&rdquo; he added. &ldquo;So I would love to see Lucasfilm embrace a short-form novella version for telling some of their stories.&rdquo; &nbsp;Solo: A Star Wars Story co-writer also admitted &ldquo;the biggest problem that has always haunted me about Solo&ldquo;: the logistics of the heist that serves as the movie&rsquo;s central plot, in which crime lord Dryden Vos (Paul Bettany) forces Han and Chewie&rsquo;s newfound gang to steal an element called coaxium. Kasdan further adds, &ldquo;If Dryden Vos is so concerned about exposing his gang in the heist, why does he send his most trusted aid to be the most visible member of the team that steals the coaxium?&rdquo; asked Kasdan. Gen Bajwa advised us to support PTI, CM Elahi endorses Moonis' remarks He indicates to Qi&rsquo;ra (Emilia Clarke), Han&rsquo;s childhood friend, who comes to aid Dryden. &ldquo;It seems to me that he&rsquo;s going to have to kill her almost immediately just to separate himself from that job,&rdquo; Kasdan explained, calling the problem &ldquo;the writer&rsquo;s nightmare.&rdquo;" } </script> <script type="text/javascript"> var base_url = "https://www.nation.com.pk/"; var asset_dir = "https://www.nation.com.pk/assets/thenation/"; var local_dev = 0; var commenting_system_type = 'disqus'; var fb_app_id = 106170627023; </script> </head> <link rel="stylesheet" href="https://www.nation.com.pk/assets/thenation/css/detail_page.css" type="text/css" media="all" /> <body onload="filter_gallery('picture_gallery'); filter_regional('lahore')" style="zoom: 1;"> <div id="fb-root"></div> <script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_GB/sdk.js#xfbml=1&version=v2.12'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk')); </script> <nav class="pushy pushy-left block-2"> <ul> <li class="mobile-only"> <a href="https://www.nation.com.pk/"><img height="65" src="https://www.nation.com.pk/assets/thenation/images/logo_footer.png"></a> </li> <li> <a href="/E-Paper" class="sf-with-ul"> e-Paper </a> </li> <li> <a href="/Todays-Paper" class="sf-with-ul"> Today's Paper </a> </li> <li> <a href="javascript:void(0);"> EDITOR'S PICKS </a> <ul class="block-39"> <li><a href="https://www.nation.com.pk/newspaper-picks" title="Newspaper Picks">Newspaper Picks</a> </li> </ul> </li> <li> <a href="javascript:void(0);"> OPINION </a> <ul class="block-37"> <li><a href="https://www.nation.com.pk/editorials" title="Editorials">Editorials</a> </li> <li><a href="https://www.nation.com.pk/columns" title="Columns">Columns</a> </li> <li><a href="https://www.nation.com.pk/letters" title="Letters">Letters</a> </li> </ul> </li> <li> <a href="javascript:void(0);"> NEWS </a> <ul class="block-36"> <li><a href="/latest" title="Latest">Latest</a> </li> <li><a href="https://www.nation.com.pk/headlines" title="Headlines">Headlines</a> </li> <li><a href="https://www.nation.com.pk/top-stories" title="Top Stories">Top Stories</a> </li> <li><a href="https://www.nation.com.pk/national" title="National">National</a> </li> <li><a href="https://www.nation.com.pk/sports" title="Sports">Sports</a> </li> <li><a href="https://www.nation.com.pk/lifestyle-entertainment" title="Lifestyle & Entertainment">Lifestyle & Entertainment</a> </li> <li><a href="https://www.nation.com.pk/business" title="Business">Business</a> </li> <li><a href="https://www.nation.com.pk/international" title="International">International</a> </li> <li><a href="https://www.nation.com.pk/editors-picks" title="Editor's Picks">Editor's Picks</a> </li> <li><a href="https://www.nation.com.pk/snippets" title="Snippets">Snippets</a> </li> <li><a href="https://www.nation.com.pk/lahore" title="Lahore">Lahore</a> </li> <li><a href="https://www.nation.com.pk/karachi" title="Karachi">Karachi</a> </li> <li><a href="https://www.nation.com.pk/islamabad" title="Islamabad">Islamabad</a> </li> </ul> </li> <li> <a href="javascript:void(0);"> MULTIMEDIA </a> <ul class="block-38"> <li><a href="https://www.nation.com.pk/news-in-pictures" title="News In Pictures">News In Pictures</a> </li> <li><a href="https://www.nation.com.pk/cartoons" title="Cartoons">Cartoons</a> </li> <li><a href="https://www.nation.com.pk/videos" title="Videos">Videos</a> </li> </ul> </li> <li> <a href="javascript:void(0);"> BLOGS </a> <ul class="block-41"> <li><a href="https://www.nation.com.pk/blogs" title="Blogs">Blogs</a> </li> <li><a href="/write-for-us" title="Write for Us">Write for Us</a> </li> </ul> </li> </ul> </nav> <div class="site-overlay"></div> <div id="container" style="overflow-x: hidden;"> <header> <div class="row"> <div class="twelve columns"> <nav class="topbar"> <div class="seven columns"> <ul class="sf-menu block-81" id="tobar"> <li class="head-li"><a style="cursor:auto;"href="javascript:void(0);"> NAWAIWAQT GROUP <i style="padding-left: 10px;"class="fa fa-caret-right"></i></a></li> <li> <a href="javascript:void(0);"> News Paper & TV Channel </a> <ul class="block-82"> <li><a href="https://www.nawaiwaqt.com.pk/" target="_blank" title="Roznama Nawaiwaqt ">Roznama Nawaiwaqt </a> </li> <li><a href="https://www.waqtnews.tv/" target="_blank" title="Waqt News TV">Waqt News TV</a> </li> </ul> </li> <li> <a href="javascript:void(0);"> Magazines </a> <ul class="block-83"> <li><a href="https://sunmag.nawaiwaqt.com.pk/" target="_blank" title="Sunday Magazine">Sunday Magazine</a> </li> <li><a href="https://family.nawaiwaqt.com.pk/" target="_blank" title="Family Magazine">Family Magazine</a> </li> <li><a href="https://nidaimillat.nawaiwaqt.com.pk/" target="_blank" title="Nidai Millat">Nidai Millat</a> </li> <li><a href="https://www.phool.com.pk/" target="_blank" title="Mahnama Phool">Mahnama Phool</a> </li> </ul> </li> </ul> </div> <div class="five columns"> <ul class="sf-menu" id="topsearch"> <li> <div class="input-container"> <form action="//www.google.com.pk" id="cse-search-box" target="_blank"> <div> <input type="hidden" name="cx" value="partner-pub-2495428981136420:9301056575"> <input type="hidden" name="ie" value="UTF-8"> <input class="custom-text" type="text" name="q" placeholder="Custom Search" style="border: 1px solid rgb(126, 157, 185); padding: 2px; background: url('https://www.google.com/cse/static/images/1x/googlelogo_lightgrey_46x16dp.png') left center no-repeat rgb(255, 255, 255); text-indent: 48px;"> </div> <div class="icon-ph"> <button type="submit"><i class="fa fa-search"></i></button> </div> <input name="siteurl" type="hidden" value="https://www.nation.com.pk/"><input name="ref" type="hidden" value=""><input name="ss" type="hidden" value=""></form></div> </li> <li class="head-date">Monday | December 05, 2022 </li> </ul> </div> </nav> </div> </div> <div class="clear"></div> <div class="row"> <div class="twelve columns"> <div class="row"> <div class="two columns hidden-mobile"> <a href="https://www.nation.com.pk/"> <img class="logo" src="https://www.nation.com.pk/uploads/theme/logo-1550475639.png" alt="logo" title=""> </a> </div> <div class="ten columns"> <div class="banner8 header-banner"> <div id='div-gpt-ad-1664962363141-0' style='min-width: 300px; min-height: 90px;'> <script> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1664962363141-0'); }); </script> </div> <style> #div-gpt-ad-1664962363141-0 div iframe { margin: 20px auto; display: block; } </style> </div> </div> </div> </div> </div> <div class="clear"></div> <div class="row"> <div class="twelve columns"> <div class='input-container search-bar-mbl'> <form action="//www.google.com.pk" id="cse-search-box" target="_blank" style="margin-bottom: 0px;"> <div> <input type="hidden" name="cx" value="partner-pub-2495428981136420:9301056575" /> <input type="hidden" name="cof" value="FORID:10" /> <input type="hidden" name="ie" value="UTF-8" /> <input class="custom-text" type="text" name="q" placeholder="" /> </div> <div class="icon-ph"> <button type="submit"><i class="fa fa-search"></i></button></div> </form></div> <ul class="nav-bar logos text-center hidden-desktop" style="text-align: center;height: 140px;margin: 0;"> <li style="display: inline-block;"> <a href="https://www.nation.com.pk/"> <img class="logo" src="https://www.nation.com.pk/uploads/theme/logo-1550475639.png" alt="logo" title=""> </a> </li> <div id="logos" class="menu-btn" style="width: 0px;position: relative;right: 35px;top: 40px;"><i class="fa fa-reorder"></i> </div> </ul> <div id="nav-bar" > <nav class="mainbar twelve columns" id="mainbar"> <!-- <div class="two columns logo-header hidden-lg"> <a href="https://www.nation.com.pk/"><img class="logo" src="https://www.nation.com.pk/uploads/theme/logo-1550475639.png" alt="" title=""></a> </div>--> <div class="ten columns header" style="padding-left: 0px;"> <ul id="barnav" class="sf-menu nav-bar block-3" > <form method="post"><input type="hidden" name="selected_menu_id" id="selected_menu_id"></form> <li id="525"> <a href="/E-Paper" > e-Paper </a> </li> <li id="526"> <a href="/Todays-Paper" > Today's Paper </a> </li> <li id="EDITOR'S PICKS"> <a href="javascript:void(0);"> EDITOR'S PICKS </a> <ul class="block-39"> <li><a href="https://www.nation.com.pk/newspaper-picks" title="Newspaper Picks">Newspaper Picks</a> </li> </ul> </li> <li id="OPINION"> <a href="javascript:void(0);"> OPINION </a> <ul class="block-37"> <li><a href="https://www.nation.com.pk/editorials" title="Editorials">Editorials</a> </li> <li><a href="https://www.nation.com.pk/columns" title="Columns">Columns</a> </li> <li><a href="https://www.nation.com.pk/letters" title="Letters">Letters</a> </li> </ul> </li> <li id="NEWS"> <a href="javascript:void(0);"> NEWS </a> <ul class="block-36"> <li><a href="/latest" title="Latest">Latest</a> </li> <li><a href="https://www.nation.com.pk/headlines" title="Headlines">Headlines</a> </li> <li><a href="https://www.nation.com.pk/top-stories" title="Top Stories">Top Stories</a> </li> <li><a href="https://www.nation.com.pk/national" title="National">National</a> </li> <li><a href="https://www.nation.com.pk/sports" title="Sports">Sports</a> </li> <li><a href="https://www.nation.com.pk/lifestyle-entertainment" title="Lifestyle & Entertainment">Lifestyle & Entertainment</a> </li> <li><a href="https://www.nation.com.pk/business" title="Business">Business</a> </li> <li><a href="https://www.nation.com.pk/international" title="International">International</a> </li> <li><a href="https://www.nation.com.pk/editors-picks" title="Editor's Picks">Editor's Picks</a> </li> <li><a href="https://www.nation.com.pk/snippets" title="Snippets">Snippets</a> </li> <li><a href="https://www.nation.com.pk/lahore" title="Lahore">Lahore</a> </li> <li><a href="https://www.nation.com.pk/karachi" title="Karachi">Karachi</a> </li> <li><a href="https://www.nation.com.pk/islamabad" title="Islamabad">Islamabad</a> </li> </ul> </li> <li id="MULTIMEDIA"> <a href="javascript:void(0);"> MULTIMEDIA </a> <ul class="block-38"> <li><a href="https://www.nation.com.pk/news-in-pictures" title="News In Pictures">News In Pictures</a> </li> <li><a href="https://www.nation.com.pk/cartoons" title="Cartoons">Cartoons</a> </li> <li><a href="https://www.nation.com.pk/videos" title="Videos">Videos</a> </li> </ul> </li> <li id="BLOGS"> <a href="javascript:void(0);"> BLOGS </a> <ul class="block-41"> <li><a href="https://www.nation.com.pk/blogs" title="Blogs">Blogs</a> </li> <li><a href="/write-for-us" title="Write for Us">Write for Us</a> </li> </ul> </li> </ul> </div> <div class="two columns"> <div class="other_clients"> <span> <a href="javascript:void(0)" onmouseover="_gaq.push()" class="cart-contents right" style="color: white;">Connect with us</a></span> <ul id="social_widget_box_header" class="other_clients_list" style="direction: rtl; position: absolute; margin-left: -202px; padding: 2px; width: 330px; text-align: center; list-style: none; margin-top: 15px; background:#999c; box-shadow: 5px 8px 10px 1px #000000"> <li style="padding: 0px; width: 100%; margin: 10px 0px;"> <div class="connect_with_us_container"> <div class="inner_box" style="height:30px"> <input type="hidden" value="Subscriber" id="name"> <input type="text" class="subscribe_text" id="email_address" placeholder="Enter eMail to Subscribe" autocomplete="off"> <input type="Submit" id="submit_btn" class="alert button" name="submit_btn" value="Subscribe" onclick="xajax_email_subscriber_add_xajax($('#name').val(), $('#email_address').val())"> </div></div> </li> <li style="list-style: none;padding-top: 0px; width: 100%; background: #efefef; "> <div class="claer">&nbsp;</div> <div class="connect_with_us_container"> <div class="inner_box"> <div class="social_icons"> <div class="social_icon"> <a href="https://www.facebook.com/thenationdaily" target="_blank" title="The Nation on Facebook"> <img src="https://www.nation.com.pk/assets/thenation/images/client/icons/facebook.png" alt="Facebook"> </a> <div class="claer"></div> <div class="text"> <a href="https://www.facebook.com/thenationdaily" target="_blank" title="The Nation on Facebook"> Facebook </a> </div> </div> <div class="social_icon"> <a href="https://twitter.com/the_nation" target="_blank" title="The Nation on Twitter"> <img src="https://www.nation.com.pk/assets/thenation/images/client/icons/twitter.png" alt="Twitter"> </a> <div class="claer"></div> <div class="text"> <a href="https://twitter.com/the_nation" target="_blank" title="The Nation on Twitter"> Twitter </a> </div> </div> <div class="social_icon"> <a href="https://plus.google.com/u/0/115838299064855338857" target="_blank" title="The Nation on Google Plus"> <img src="https://www.nation.com.pk/assets/thenation/images/client/icons/g_plus.png" alt="The Nation on Google Plus"> </a> <div class="claer"></div> <div class="text"> <a href="https://plus.google.com/u/0/115838299064855338857" target="_blank" title="The Nation on Google Plus"> Google Plus </a> </div> </div> <div class="social_icon"> <a href="https://nation.com.pk/rss" target="_blank" title="Subscribe to our RSS feed"> <img src="https://www.nation.com.pk/assets/thenation/images/client/icons/rsss.png" alt="Subscribe to our RSS feed"> </a> <div class="claer"></div> <div class="text"> <a href="https://nation.com.pk/rss" target="_blank" title="Subscribe to our RSS feed"> RSS </a> </div> </div> <div class="social_icon"> <a href="http://youtube.com/WaqtNews" target="_blank" title="The Nation on Youtube"> <img src="https://www.nation.com.pk/assets/thenation/images/client/icons/utube.png" alt="The Nation on Youtube"> </a> <div class="claer"></div> <div class="text"> <a href="http://youtube.com/WaqtNews" target="_blank" title="The Nation on Youtube"> Youtube </a> </div> </div> </div> </div> <div class="claer">&nbsp;</div> <div class="inner_box"> <div class="" style="margin-left: 12px;background: #fff;padding-top: 15px;border-radius: 5px;padding-right: 5px;margin-right: 13px;padding-left: 5px;"> <iframe src="https://www.facebook.com/plugins/like.php?href=https%3A%2F%2Fwww.facebook.com%2Fthenationdaily&width=300&layout=standard&action=like&size=small&show_faces=true&share=true&height=80&appId=242296922463600" width="300" height="80" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe> </div> <div class="d" style="margin-left: 12px;margin-right: 12px;float: left;border-radius: 5px;padding: 5px 5px;margin-top: 15px;background: #fff;text-align: left;width: 92%;"> <a href="https://twitter.com/the_nation" class="twitter-follow-button" data-show-count="true">Follow @the_nation</a> </div> </div> <div class="claer">&nbsp;</div> </div> </li> <li style="padding: 0px; width: 103%;"> <div class="app_icons"> <a href="https://play.google.com/store/apps/details?id=com.flipinfo.thenation" target="_blank"> <img src="https://www.nation.com.pk/assets/thenation/images/client/icons/android_app_on_play_logo_small.png" height="43px" alt="play_store"> </a> <a href="https://itunes.apple.com/us/app/thenationnewspaper/id582976156" target="_blank"> <img src="https://www.nation.com.pk/assets/thenation/images/client/icons/app-store.png" height="43px" alt="apple_itunes"> </a> </div> </li> </ul> </div> </div> </nav> </div> <div class="panel white block-4" id="news_ticker"> <div class="one columns"> <div class="trending">Latest</div> </div> <div class="eleven columns"> <div class="tickercontainer"> <div class="mask"> <ul id="ticker01"> <li> <span>11:01 PM | December 04, 2022</span> <a href="https://www.nation.com.pk/04-Dec-2022/gen-bajwa-advised-us-to-support-pti-cm-elahi-endorses-moonis-remarks">Gen Bajwa advised us to support PTI, CM Elahi endorses Moonis' remarks</a> </li> <li> <span>9:04 PM | December 04, 2022</span> <a href="https://www.nation.com.pk/04-Dec-2022/leas-tightening-noose-against-blasphemers-on-social-media">LEAs tightening noose against blasphemers on social media</a> </li> <li> <span>9:02 PM | December 04, 2022</span> <a href="https://www.nation.com.pk/04-Dec-2022/sirajul-haq-reveals-he-refused-zardari-s-request-to-help-him-against-pti">Sirajul Haq reveals he refused Zardari's request to help him against PTI</a> </li> <li> <span>8:02 PM | December 04, 2022</span> <a href="https://www.nation.com.pk/04-Dec-2022/bise-multan-pays-dues-to-heirs-of-deceased-staffers-on-po-s-orders">BISE Multan pays dues to heirs of deceased staffers on PO’s orders</a> </li> <li> <span>7:06 PM | December 04, 2022</span> <a href="https://www.nation.com.pk/04-Dec-2022/atta-tarar-hits-out-at-pti-over-vicious-campaign-against-ex-army-chief"> Atta Tarar hits out at PTI over vicious campaign against ex-army chief</a> </li> </ul> </div> </div> </div> </div> </div> </div> </header> <!-- End Header and Nav --> <div class="row"> <div class="twelve columns"> <section id="maincontainer"> <div class="eight columns "> <div id="content"> <section id="singlepost" class="detail-page"> <header> <h1 >‘Star Wars’ writer wants to follow Marvel model for franchise</h1> </header> <article> <div class="share-head">Share:</div> <div class="postmeta postmetaone"> <div class="article-share" style="margin: 0 auto;text-align: center;"> <div class="fb-save" data-uri="https://www.facebook.com/thenationdaily/" data-size="small"></div> <div class="fb-like" data-href="https://nation.com.pk/" data-layout="button_count" data-action="like" data-size="small" data-show-faces="true" data-share="false"></div> <div class="fb-share-button" data-href="https://www.nation.com.pk/05-Dec-2022/star-wars-writer-wants-to-follow-marvel-model-for-franchise" data-layout="button" data-size="small" data-mobile-iframe="true"><a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fnation.com.pk%2F&amp;src=sdkpreparse" class="fb-xfbml-parse-ignore">Share</a></div> <a href="https://twitter.com/intent/tweet" class="twitter-share-button" data-url="https://www.nation.com.pk/05-Dec-2022/star-wars-writer-wants-to-follow-marvel-model-for-franchise" data-counturl="https://www.nation.com.pk/05-Dec-2022/star-wars-writer-wants-to-follow-marvel-model-for-franchise" data-lang="en" data-count="horizontal">Tweet</a><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.nation.com.pk/05-Dec-2022/star-wars-writer-wants-to-follow-marvel-model-for-franchise&title=‘Star Wars’ writer wants to follow Marvel model for franchise" onclick="window.open(this.href, 'mywin', 'left=20,top=20,width=500,height=500,toolbar=1,resizable=0'); return false;"> <img style="width: 58px;" src="https://www.nation.com.pk/assets/thenation/images/linkedin_share.png" /> </a> <a href="whatsapp://send?text=https://www.nation.com.pk/05-Dec-2022/star-wars-writer-wants-to-follow-marvel-model-for-franchise" class="whatsapp-mobile"> <img style="height:20px;" class="fb_share_detail_page" src="https://www.nation.com.pk/assets/thenation/images/client/whatsapp_share.png" alt="Whatsapp" /> </a> <a class="whatsapp_web" style="margin-left:13px;" target="_blank" href="https://web.whatsapp.com/send?text=https://www.nation.com.pk/05-Dec-2022/star-wars-writer-wants-to-follow-marvel-model-for-franchise" data-action="share/whatsapp/share" class="wa_btn wa_btn_s"> <img style="height:20px;" class="fb_share_detail_page" src="https://www.nation.com.pk/assets/thenation/images/client/whatsapp_share.png" alt="Whatsapp" /> </a> </div> </div> <div class="imgpost"> <div > <picture> <source srcset="https://www.nation.com.pk/print_images/large/2022-12-05/star-wars-writer-wants-to-follow-marvel-model-for-franchise-1670188653-6064.jpg" media="(min-width: 1024px)" /> <img width="750" height="400" src="https://www.nation.com.pk/print_images/medium/2022-12-05/star-wars-writer-wants-to-follow-marvel-model-for-franchise-1670188653-6064.jpg" class="img-responsive detailpage-single-img" alt="‘Star Wars’ writer wants to follow Marvel model for franchise"/> </picture> </div> </div> <div class="authorpost" > <div class="thumbauthor"> <a href="https://www.nation.com.pk/reporter/news-desk" > <div style="height:80px; border-radius:10px; background: url(https://www.nation.com.pk/assets/thenation/images/no-image-author-small.jpg)" title="‘Star Wars’ writer wants to follow Marvel model for franchise" class="img_bckg"></div> </a> </div> <div class="authorname"> <h3 > <a class="authorname_coulum" href="https://www.nation.com.pk/reporter/news-desk">News Desk</a> </h3> <p class="meta-date">December 05, 2022</p> </div> </div> <div class="banner8 header-banner"> <div id='div-gpt-ad-1665039207874-0' style='min-width: 300px; min-height: 90px;'> <script> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1665039207874-0'); }); </script> </div> <style> #div-gpt-ad-1665039207874-0 div iframe { margin: 20px auto; display: block; } </style> </div> <div class="post-content" > <p style="text-align: justify;"><p style="text-align: justify;">NEW YORK-Star Wars writer Jonathan Kasdan wants to replicate the Marvel model to tell stories in the franchise after being inspired by Marvel&rsquo;s recent Werewolf by Night show. During an interview with The Hollywood Reporter, Kasdan said, &ldquo;In recent months, I have been intrigued by the wonderful Werewolf by Night as a potential form of storytelling on Disney+,&rdquo; he added. &ldquo;So I would love to see Lucasfilm embrace a short-form novella version for telling some of their stories.&rdquo; &nbsp;Solo: A <a href="https://www.nation.com.pk/tag/star wars">Star Wars</a> Story co-writer also admitted &ldquo;the biggest problem that has always haunted me about Solo&ldquo;: the logistics of the heist that serves as the movie&rsquo;s central plot, in which crime lord Dryden Vos (Paul Bettany) forces Han and Chewie&rsquo;s newfound gang to steal an element called coaxium. Kasdan further adds, &ldquo;If Dryden Vos is so concerned about exposing his gang in the heist, why does he send his most trusted aid to be the most visible member of the team that steals the coaxium?&rdquo; asked Kasdan.</p> <p><blockquote class="oembed_ltr"> <div class="oembed_image" style=""> <div class="top-center" title="https://www.nation.com.pk/04-Dec-2022/gen-bajwa-advised-us-to-support-pti-cm-elahi-endorses-moonis-remarks" style="height:55px;background-image:url(https://www.nation.com.pk/digital_images/medium/2022-12-04/gen-bajwa-advised-us-to-support-pti-cm-elahi-endorses-moonis-remarks-1670176889-2533.jpg);" ></div> </div> <div class="oembed_title"> <a href="https://www.nation.com.pk/04-Dec-2022/gen-bajwa-advised-us-to-support-pti-cm-elahi-endorses-moonis-remarks" >Gen Bajwa advised us to support PTI, CM Elahi endorses Moonis' remarks</a> </div> </blockquote> <div class="clearfix"></div></p> <p>He indicates to Qi&rsquo;ra (Emilia Clarke), Han&rsquo;s childhood friend, who comes to aid Dryden. &ldquo;It seems to me that he&rsquo;s going to have to kill her almost immediately just to separate himself from that job,&rdquo; Kasdan explained, calling the problem &ldquo;the writer&rsquo;s nightmare.&rdquo;</p></p> </div> <div class="postmeta"> <div class="article-share" style="margin: 0 auto;text-align: center;"> <div class="fb-save" data-uri="https://www.facebook.com/thenationdaily/" data-size="small"></div> <div class="fb-like" data-href="https://nation.com.pk/" data-layout="button_count" data-action="like" data-size="small" data-show-faces="true" data-share="false"></div> <div class="fb-share-button" data-href="https://www.nation.com.pk/05-Dec-2022/star-wars-writer-wants-to-follow-marvel-model-for-franchise" data-layout="button" data-size="small" data-mobile-iframe="true"><a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fnation.com.pk%2F&amp;src=sdkpreparse" class="fb-xfbml-parse-ignore">Share</a></div> <a href="https://twitter.com/intent/tweet" class="twitter-share-button" data-url="https://www.nation.com.pk/05-Dec-2022/star-wars-writer-wants-to-follow-marvel-model-for-franchise" data-counturl="https://www.nation.com.pk/05-Dec-2022/star-wars-writer-wants-to-follow-marvel-model-for-franchise" data-lang="en" data-count="horizontal">Tweet</a><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.nation.com.pk/05-Dec-2022/star-wars-writer-wants-to-follow-marvel-model-for-franchise&title=‘Star Wars’ writer wants to follow Marvel model for franchise" onclick="window.open(this.href, 'mywin', 'left=20,top=20,width=500,height=500,toolbar=1,resizable=0'); return false;"> <img style="width: 58px;" src="https://www.nation.com.pk/assets/thenation/images/linkedin_share.png" /> </a> <a href="whatsapp://send?text=https://www.nation.com.pk/05-Dec-2022/star-wars-writer-wants-to-follow-marvel-model-for-franchise" class="whatsapp-mobile"> <img style="height:20px;" class="fb_share_detail_page" src="https://www.nation.com.pk/assets/thenation/images/client/whatsapp_share.png" alt="Whatsapp" /> </a> <a class="whatsapp_web" style="margin-left:13px;" target="_blank" href="https://web.whatsapp.com/send?text=https://www.nation.com.pk/05-Dec-2022/star-wars-writer-wants-to-follow-marvel-model-for-franchise" data-action="share/whatsapp/share" class="wa_btn wa_btn_s"> <img style="height:20px;" class="fb_share_detail_page" src="https://www.nation.com.pk/assets/thenation/images/client/whatsapp_share.png" alt="Whatsapp" /> </a> </div> </div> <div class="head-share2">Share:</div> <div class="fb-quote"></div> <div class="banner8"> <div id='div-gpt-ad-1665039486075-0' style='min-width: 300px; min-height: 90px;'> <script> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1665039486075-0'); }); </script> </div> <style> #div-gpt-ad-1665039486075-0 div iframe { margin: 20px auto; display: block; } </style> </div> <div class="clear"></div> <!-- <div class="post-author"> <div class="at-desc"> <div class="at-name"> More by <div itemscope="News Desk" itemtype="//schema.org/Person"> <div itemprop="name" > <a itemprop="url" href="https://www.nation.com.pk/reporter/news-desk">News Desk</a> </div> </div> </div> </div> </div>--> </article> </section> <div class="clear clearfix"></div> <section id="postwidget"> <section id="cat2news"> <div class="othercat othercat1"> <h3 class="blocktitle block-27" style="text-transform: uppercase;" >RELATED NEWS </h3> <ul class="oc-horizon"> <li class="bck_li" > <div class="octhumb bck_li_octhumb"> <a href="https://www.nation.com.pk/16-Nov-2022/wagatha-play-won-t-punch-down-at-rebekah-vardy-and-coleen-rooney-says-writer"> <div alt="Wagatha play won’t punch down at Rebekah Vardy and Coleen Rooney, says writer" style="height:82px; width: 82px; background: url(https://www.nation.com.pk/print_images/medium/2022-11-16/wagatha-play-won-t-punch-down-at-rebekah-vardy-and-coleen-rooney-says-writer-1668564393-4788.jpg)" title="Wagatha play won’t punch down at Rebekah Vardy and Coleen Rooney, says writer" class="img_bckg"></div> </a> </div> <div class="desc" style="padding-left: 92px; position: relative; float: left;"> <a class="spec-time" href="https://www.nation.com.pk/16-Nov-2022/wagatha-play-won-t-punch-down-at-rebekah-vardy-and-coleen-rooney-says-writer">November 16, 2022</a> <h4 ><a href="https://www.nation.com.pk/16-Nov-2022/wagatha-play-won-t-punch-down-at-rebekah-vardy-and-coleen-rooney-says-writer"> Wagatha play won’t punch down at Rebekah Vardy and Coleen Rooney, says writer</a></h4> </div> </li> <li class="bck_li" > <div class="octhumb bck_li_octhumb"> <a href="https://www.nation.com.pk/07-Nov-2022/aminul-haq-tells-ishaq-dar-to-change-his-attitude-follow-pm-s-instructions"> <div alt="Aminul Haq tells Ishaq Dar to change his attitude, follow PM’s instructions" style="height:82px; width: 82px; background: url(https://www.nation.com.pk/digital_images/medium/2022-11-07/aminul-haq-tells-ishaq-dar-to-change-his-attitude-follow-pm-s-instructions-1667831189-2855.jpg)" title="Aminul Haq tells Ishaq Dar to change his attitude, follow PM’s instructions" class="img_bckg"></div> </a> </div> <div class="desc" style="padding-left: 92px; position: relative; float: left;"> <a class="spec-time" href="https://www.nation.com.pk/07-Nov-2022/aminul-haq-tells-ishaq-dar-to-change-his-attitude-follow-pm-s-instructions">7:25 PM | November 07, 2022</a> <h4 ><a href="https://www.nation.com.pk/07-Nov-2022/aminul-haq-tells-ishaq-dar-to-change-his-attitude-follow-pm-s-instructions"> Aminul Haq tells Ishaq Dar to change his attitude, follow PM’s instructions</a></h4> </div> </li> <li class="bck_li" > <div class="octhumb bck_li_octhumb"> <a href="https://www.nation.com.pk/10-Nov-2022/commissioner-urges-youth-to-follow-iqbal-s-philosophy-for-development-of-nation"> <div alt="" style="height:82px; width: 82px; background: url(https://www.nation.com.pk/assets/thenation/images/no-image-medium.jpg)" title="Commissioner urges youth to follow Iqbal’s philosophy for development  of nation" class="img_bckg"></div> </a> </div> <div class="desc" style="padding-left: 92px; position: relative; float: left;"> <a class="spec-time" href="https://www.nation.com.pk/10-Nov-2022/commissioner-urges-youth-to-follow-iqbal-s-philosophy-for-development-of-nation">November 10, 2022</a> <h4 ><a href="https://www.nation.com.pk/10-Nov-2022/commissioner-urges-youth-to-follow-iqbal-s-philosophy-for-development-of-nation"> Commissioner urges youth to follow Iqbal’s philosophy for development  of nation</a></h4> </div> </li> <li class="bck_li" > <div class="octhumb bck_li_octhumb"> <a href="https://www.nation.com.pk/18-Nov-2022/cjp-directs-imran-khan-to-follow-law-during-pti-s-long-march"> <div alt="CJP directs Imran Khan to follow law during PTI’s long march" style="height:82px; width: 82px; background: url(https://www.nation.com.pk/digital_images/medium/2022-11-18/cjp-directs-imran-khan-to-follow-law-during-pti-s-long-march-1668766325-9808.jpeg)" title="CJP directs Imran Khan to follow law during PTI’s long march" class="img_bckg"></div> </a> </div> <div class="desc" style="padding-left: 92px; position: relative; float: left;"> <a class="spec-time" href="https://www.nation.com.pk/18-Nov-2022/cjp-directs-imran-khan-to-follow-law-during-pti-s-long-march">3:12 PM | November 18, 2022</a> <h4 ><a href="https://www.nation.com.pk/18-Nov-2022/cjp-directs-imran-khan-to-follow-law-during-pti-s-long-march"> CJP directs Imran Khan to follow law during PTI’s long march</a></h4> </div> </li> </ul> </div> <div class="othercat othercat1"> <h3 class="blocktitle block-96" style="text-transform: uppercase;" >Top Stories </h3> <ul class="oc-horizon"> <li class="bck_li" > <div class="octhumb bck_li_octhumb"> <a href="https://www.nation.com.pk/04-Dec-2022/swati-handed-over-to-balochistan-police-in-tweet-case"> <div alt="Swati handed over to Balochistan police in tweet case" style="height:82px; width: 82px; background: url(https://www.nation.com.pk/digital_images/medium/2022-12-04/swati-handed-over-to-balochistan-police-in-tweet-case-1670139633-2633.jpg)" title="Swati handed over to Balochistan police in tweet case" class="img_bckg"></div> </a> </div> <div class="desc" style="padding-left: 92px; position: relative; float: left;"> <a class="spec-time" href="https://www.nation.com.pk/04-Dec-2022/swati-handed-over-to-balochistan-police-in-tweet-case">12:40 PM | December 04, 2022</a> <h4 ><a href="https://www.nation.com.pk/04-Dec-2022/swati-handed-over-to-balochistan-police-in-tweet-case"> Swati handed over to Balochistan police in tweet case</a></h4> </div> </li> <li class="bck_li" > <div class="octhumb bck_li_octhumb"> <a href="https://www.nation.com.pk/04-Dec-2022/cm-kp-says-he-will-dissolve-assembly-at-imran-s-behest"> <div alt="CM KP says he will dissolve assembly at Imran's behest" style="height:82px; width: 82px; background: url(https://www.nation.com.pk/digital_images/medium/2022-12-04/will-dissolve-assembly-at-imran-s-behest-kp-cm-1670136083-1925.png)" title="CM KP says he will dissolve assembly at Imran's behest" class="img_bckg"></div> </a> </div> <div class="desc" style="padding-left: 92px; position: relative; float: left;"> <a class="spec-time" href="https://www.nation.com.pk/04-Dec-2022/cm-kp-says-he-will-dissolve-assembly-at-imran-s-behest">11:49 AM | December 04, 2022</a> <h4 ><a href="https://www.nation.com.pk/04-Dec-2022/cm-kp-says-he-will-dissolve-assembly-at-imran-s-behest"> CM KP says he will dissolve assembly at Imran's behest</a></h4> </div> </li> <li class="bck_li" > <div class="octhumb bck_li_octhumb"> <a href="https://www.nation.com.pk/02-Dec-2022/dr-asad-majeed-appointed-foreign-secretary-of-pakistan"> <div alt="Dr Asad Majeed appointed foreign secretary of Pakistan" style="height:82px; width: 82px; background: url(https://www.nation.com.pk/digital_images/medium/2022-12-02/dr-asad-majeed-appointed-foreign-secretary-of-pakistan-1669971682-5588.jpg)" title="Dr Asad Majeed appointed foreign secretary of Pakistan" class="img_bckg"></div> </a> </div> <div class="desc" style="padding-left: 92px; position: relative; float: left;"> <a class="spec-time" href="https://www.nation.com.pk/02-Dec-2022/dr-asad-majeed-appointed-foreign-secretary-of-pakistan">2:01 PM | December 02, 2022</a> <h4 ><a href="https://www.nation.com.pk/02-Dec-2022/dr-asad-majeed-appointed-foreign-secretary-of-pakistan"> Dr Asad Majeed appointed foreign secretary of Pakistan</a></h4> </div> </li> <li class="bck_li" > <div class="octhumb bck_li_octhumb"> <a href="https://www.nation.com.pk/30-Nov-2022/pm-shehbaz-rules-out-risks-of-default"> <div alt="PM Shehbaz rules out ‘risks of default’" style="height:82px; width: 82px; background: url(https://www.nation.com.pk/print_images/medium/2022-11-30/pm-shehbaz-rules-out-risks-of-default-1669767583-2356.jpg)" title="PM Shehbaz rules out ‘risks of default’" class="img_bckg"></div> </a> </div> <div class="desc" style="padding-left: 92px; position: relative; float: left;"> <a class="spec-time" href="https://www.nation.com.pk/30-Nov-2022/pm-shehbaz-rules-out-risks-of-default">November 30, 2022</a> <h4 ><a href="https://www.nation.com.pk/30-Nov-2022/pm-shehbaz-rules-out-risks-of-default"> PM Shehbaz rules out ‘risks of default’</a></h4> </div> </li> </ul> </div> </section> </section> <div class="line1"></div> <div class="clear clearfix"></div> <div class="twelve columns listcomments"> </div> </div> </div> <div class="four columns gridleft"> <aside> <div class="widget"> <div style="margin-top:10px; margin-bottom: 10px; margin-left: 12%; margin-right: 12%;"> <div id='div-gpt-ad-1664963951820-0' style='min-width: 300px; min-height: 600px;'> <script> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1664963951820-0'); }); </script> </div> </div> </div> <div class="widget block-29 "> <h3 class="blocktitle">E-paper</h3> <div class="getcat"> <div class="lthumb" style="height: auto;"> <a href="/E-Paper"> <img src="https://www.nation.com.pk/epaper_image/medium/2022-12-04/Lahore/epaper_img_1670127540.gif" /> </a> </div> </div> </div> <div class="widget wlistcat block-62"> <h3 class="blocktitle" style="text-transform: uppercase;">Cartoons<span><a href="https://www.nation.com.pk/cartoons">More</a></span></h3> <div class="getcat"> <div class="lthumb orignal_height"> <a href="https://www.nation.com.pk/17-May-2019/aids"> <img alt="AIDS" src="https://www.nation.com.pk/print_images/medium/2019-05-17/aids-1558039216-5601.jpg"> </a> </div> <a href="https://www.nation.com.pk/17-May-2019/aids"><h2 class="wtitle">AIDS</h2></a> </div> </div> <div class="widget wlistcat block-64"> <h3 class="blocktitle" style="text-transform: uppercase;">Columns <span><a href="https://www.nation.com.pk/columns" title="Columns">MORE</a></span> </h3> <div class="getcat"> <ul class="catlist"> <li style="border-top:none;"><a href="https://www.nation.com.pk/05-Dec-2022/only-they-matter"> <p class="meta-date">Najm us Saqib</p> <h2 class="wtitle" >Only ‘they’ matter</h2> </a> </li> <li style="border-top:none;"><a href="https://www.nation.com.pk/05-Dec-2022/india-s-privately-launched-rocket"> <p class="meta-date">Zohaib Altaf</p> <h2 class="wtitle" >India’s Privately Launched Rocket</h2> </a> </li> <li style="border-top:none;"><a href="https://www.nation.com.pk/05-Dec-2022/health-care-for-afghan-refugees-and-migrants-in-pakistan"> <p class="meta-date">Dr Waqas Sajjad</p> <h2 class="wtitle" >Health care for Afghan refugees and migrants in Pakistan</h2> </a> </li> </ul> </div> </div> <div class="widget wlistcat block-63"> <h3 class="blocktitle" style="text-transform: uppercase;">Editorials <span><a href="https://www.nation.com.pk/editorials" title="Editorials">MORE</a></span> </h3> <div class="getcat"> <ul class="catlist"> <li style="border-top:none;"><a href="https://www.nation.com.pk/17-May-2019/lawmakers-as-lawbreakers"> <p class="meta-date">May 17, 2019</p> <h2 class="wtitle" >Lawmakers As Lawbreakers</h2> </a> </li> <li style="border-top:none;"><a href="https://www.nation.com.pk/17-May-2019/the-new-normal"> <p class="meta-date">May 17, 2019</p> <h2 class="wtitle" >The New Normal</h2> </a> </li> <li style="border-top:none;"><a href="https://www.nation.com.pk/17-May-2019/developing-a-metropolis"> <p class="meta-date">May 17, 2019</p> <h2 class="wtitle" >Developing A Metropolis</h2> </a> </li> </ul> </div> </div> <div class="widget wlistcat block-65"> <h3 class="blocktitle" style="text-transform: uppercase;">Letters <span><a href="https://www.nation.com.pk/letters" title="Letters">MORE</a></span> </h3> <div class="getcat"> <ul class="catlist"> <li style="border-top:none;"><a href="https://www.nation.com.pk/17-May-2019/increasing-water-pollution-at-seaside-in-karachi"> <p class="meta-date">May 17, 2019</p> <h2 class="wtitle" >Increasing water pollution at seaside in Karachi</h2> </a> </li> <li style="border-top:none;"><a href="https://www.nation.com.pk/17-May-2019/murder-or-medical-error"> <p class="meta-date">May 17, 2019</p> <h2 class="wtitle" >Murder or medical error?</h2> </a> </li> <li style="border-top:none;"><a href="https://www.nation.com.pk/17-May-2019/targeting-polio-vaccinators"> <p class="meta-date">May 17, 2019</p> <h2 class="wtitle" >Targeting Polio Vaccinators</h2> </a> </li> <li style="border-top:none;"><a href="https://www.nation.com.pk/17-May-2019/kudos-to-fawad-chaudhry"> <p class="meta-date">May 17, 2019</p> <h2 class="wtitle" >Kudos to Fawad Chaudhry</h2> </a> </li> <li style="border-top:none;"><a href="https://www.nation.com.pk/17-May-2019/blessings-into-curses"> <p class="meta-date">May 17, 2019</p> <h2 class="wtitle" >Blessings into curses</h2> </a> </li> </ul> </div> </div> <!-- <div class="widget"> <div class="widget wtrending"> <h3 class="blocktitle">TODAY'S POPULAR</h3> <div class="titletrend"> <span id="tabs"><a href="javascript:void(0)" onclick="show_hide('tab1', 'tab2')" class="tab1 active">MOST VIEWED</a> | <a href="javascript:void(0)" onclick="show_hide('tab2', 'tab1')" class="tab2">MOST COMMENTED</a> </span> </div> <div id="tab1"> <ul class="listtrend block-25"> <li class="wt1"> <a href="https://www.nation.com.pk/04-Dec-2022/sindh-culture-day-being-celebrated-today">Six coal miners killed in gas explosion in Harnai</a> </li> <li class="wt2"> <a href="https://www.nation.com.pk/04-Dec-2022/cm-kp-says-he-will-dissolve-assembly-at-imran-s-behest">CM KP says he will dissolve assembly at Imran's behest</a> </li> <li class="wt3"> <a href="https://www.nation.com.pk/04-Dec-2022/80-percent-area-cleared-of-floodwater-sindh-cm">80% area cleared of floodwater: Sindh CM</a> </li> <li class="wt4"> <a href="https://www.nation.com.pk/04-Dec-2022/contractor-blacklisted-over-delay-in-cpeic-extension-block-project">Contractor blacklisted over delay in CPEIC extension block project</a> </li> </ul> </div> <div id="tab2" style="display: none"> </div> </div> </div>--> <div class="clear"></div> <div class="widget"> <div id='div-gpt-ad-1665042098634-0' style='min-width: 300px; min-height: 600px;'> <script> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1665042098634-0'); }); </script> </div> <style> #div-gpt-ad-1665042098634-0 div iframe { margin: 20px auto; display: block; } </style> </div> <div class="widget"> <h3 class="blocktitle" style="margin:0px;"> E-paper - Nawaiwaqt </h3> <div class="getcat"> <div class="lthumb" style="height: auto;" target="_blank"> <a href="https://www.nawaiwaqt.com.pk/epaper"> <img src="https://www.nawaiwaqt.com.pk/epaper_image/medium/2022-12-04/Lahore/epaper_img_1670117770.gif" alt="E-paper - Nawaiwaqt "/> </a> </div> </div> </div> </aside> </div> <!--<div class="four columns gridleft"> <aside> <div class="widget"> <div style="margin-top:10px; margin-bottom: 10px; margin-left: 12%; margin-right: 12%;"> <div id='div-gpt-ad-1414124712057-4'> <script type='text/javascript'> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1414124712057-4'); }); </script> </div> </div> <div class="widget block-29 "> <h3 class="blocktitle">E-paper</h3> <div class="getcat"> <div class="lthumb" style="height: auto;"> <a href="/E-Paper"> <img src="https://www.nation.com.pk/epaper_image/medium/2022-12-04/Lahore/epaper_img_1670127540.gif" /> </a> </div> </div> </div> <div class="clear"></div> <div class="clear"></div> <div class="widget wtrending"> <h3 class="blocktitle">TODAY'S POPULAR</h3> <div class="titletrend"> <span id="tabs"><a href="javascript:void(0)" onclick="show_hide('tab1', 'tab2')" class="tab1 active">Most Viewed</a> | <a href="javascript:void(0)" onclick="show_hide('tab2', 'tab1')" class="tab2">Most Commented</a> </span> </div> <div id="tab1"> <ul class="listtrend block-25"> <li class="wt1"> <a href="https://www.nation.com.pk/04-Dec-2022/sindh-culture-day-being-celebrated-today">Six coal miners killed in gas explosion in Harnai</a> </li> <li class="wt2"> <a href="https://www.nation.com.pk/04-Dec-2022/cm-kp-says-he-will-dissolve-assembly-at-imran-s-behest">CM KP says he will dissolve assembly at Imran's behest</a> </li> <li class="wt3"> <a href="https://www.nation.com.pk/04-Dec-2022/80-percent-area-cleared-of-floodwater-sindh-cm">80% area cleared of floodwater: Sindh CM</a> </li> <li class="wt4"> <a href="https://www.nation.com.pk/04-Dec-2022/contractor-blacklisted-over-delay-in-cpeic-extension-block-project">Contractor blacklisted over delay in CPEIC extension block project</a> </li> </ul> </div> <div id="tab2" style="display: none"> </div> </div> </div> </aside> </div>--> </section> </div> </div> </div> <footer> <div class="row"> <div class="twelve columns"> <section id="footer"> <div class="four columns gridfooter"> <div class="widget"> <div class="titletrend"> <span id="tabs"> <h3 class="blocktitle" style=""> <span> <a href="javascript:void(0)" onclick="show_hide('footer_tab1', 'footer_tab2')" class="footer_tab1 active">MOST VIEWED</a> </span> | <span style="padding: 0px 0px 0px 5px;"> <a href="javascript:void(0)" onclick="show_hide('footer_tab2', 'footer_tab1')" class="footer_tab2">MOST COMMENTED</a> </span> </h3> </div> <div id="footer_tab1"> <ul class="listtrend block-25"> <li class="wt1"> <a href="https://www.nation.com.pk/04-Dec-2022/sindh-culture-day-being-celebrated-today">Six coal miners killed in gas explosion in Harnai</a> </li> <li class="wt2"> <a href="https://www.nation.com.pk/04-Dec-2022/cm-kp-says-he-will-dissolve-assembly-at-imran-s-behest">CM KP says he will dissolve assembly at Imran's behest</a> </li> <li class="wt3"> <a href="https://www.nation.com.pk/04-Dec-2022/80-percent-area-cleared-of-floodwater-sindh-cm">80% area cleared of floodwater: Sindh CM</a> </li> <li class="wt4"> <a href="https://www.nation.com.pk/04-Dec-2022/contractor-blacklisted-over-delay-in-cpeic-extension-block-project">Contractor blacklisted over delay in CPEIC extension block project</a> </li> </ul> </div> <div id="footer_tab2" style="display: none"> </div> </div> </div> <div class="four columns"> <div class="widget wcategory"> <h3 class="blocktitle"><span>ADVERTISEMENT</span></h3> <div class="tagcloud"> <div id='div-gpt-ad-1664962020792-0' style='min-width: 300px; min-height: 250px;'> <script> googletag.cmd.push(function() { googletag.display('div-gpt-ad-1664962020792-0'); }); </script> </div> <style> #div-gpt-ad-1664962020792-0 div iframe { margin: 20px auto; display: block; } </style> </div> </div> </div> <div class="four columns"> <div class="widget wcontact"> <h3 class="blocktitle"><span>CONTACT DETAILS</span></h3> <div class="dcontact"> <img style="height: 160px;" src="https://www.nation.com.pk/assets/thenation/images/logo_footer.png?date=2019-02-15" alt="TheNation"><br><p>NIPCO House, 4 - Shaharah e Fatima Jinnah,<br>Lahore, Pakistan <br>Tel: +92 42 36367580 &nbsp;&nbsp; | &nbsp; &nbsp; Fax : +92 42 36367005</p> <ul class="footer_links"> <li><a href="https://www.nation.com.pk/about-us" title="About The Nation">About Us</a></li> <li><a href="https://www.nation.com.pk/advertise-with-us" title="Advertise on The Nation">Advertise</a></li> <li><a href="https://www.nation.com.pk/contact-us" title="Contact Us">Contact Us</a></li> <li><a href="https://www.nation.com.pk/terms-conditions" title="Terms &amp; Conditions">Terms &amp; Conditions</a></li> <li><a href="https://www.nation.com.pk/privacy-policy" title="Privacy &amp; Policy">Privacy &amp; Policy</a></li> </ul> <div class="sn"> <a href="https://www.facebook.com/thenationdaily" target="_blank"><i class="fa fa-facebook"></i></a> <a href="https://plus.google.com/u/0/115838299064855338857" target="_blank"><i class="fa fa-google-plus"></i></a> <a href="https://twitter.com/the_nation" target="_blank"><i class="fa fa-twitter"></i></a> <a href="https://youtube.com/WaqtNews" target="_blank"><i class="fa fa-youtube"></i></a> <a href="https://nation.com.pk/rss" target="_blank"><i class="fa fa-rss"></i></a> </div> </div> </div> </div> <div class="row clear"></div> <div class="copyright twelve columns"> <div class="five columns">Copyright © 2022 | Nawaiwaqt Group </div> <div class="seven columns" > Powered by: <a href="http://publishrr.com/" target="_blank"><img src="https://www.nation.com.pk/assets/thenation/images/logo_publishrr.png" style="width: 90px;position: relative;top: 9px;" alt="TheNation"></a> </div> </div> <a class="toppage" href="/05-Dec-2022/star-wars-writer-wants-to-follow-marvel-model-for-franchise#container"> <i class="fa fa-chevron-up"></i> </a> </div> </section> </div> </div> </footer> <script type="text/javascript" src="https://www.nation.com.pk/assets/thenation/js/modernizr.foundation.js?mdate=1662010451"></script> <script type="text/javascript" src="https://www.nation.com.pk/assets/thenation/js/poll_widget.js?mdate=1662010451"></script> <script type="text/javascript" src="https://www.nation.com.pk/assets/thenation/js/foundation.min.js?mdate=1662010451"></script> <script type="text/javascript" src="https://www.nation.com.pk/assets/thenation/js/jquery-ui-1.8.23.custom.min.js?mdate=1662010451"></script> <script type="text/javascript" src="https://www.nation.com.pk/assets/thenation/js/jquery-easing.js?mdate=1662010451"></script> <script type="text/javascript" src="https://www.nation.com.pk/assets/thenation/js/jquery.mousewheel.min.js?mdate=1662010451"></script> <script type="text/javascript" src="https://www.nation.com.pk/assets/thenation/js/jquery.kinetic.js?mdate=1662010451"></script> <script type="text/javascript" src="https://www.nation.com.pk/assets/thenation/js/pushy.js?mdate=1662010451"></script> <script type="text/javascript" src="https://www.nation.com.pk/assets/thenation/js/plugins.js?mdate=1662010451"></script> <script type="text/javascript" src="https://www.nation.com.pk/assets/thenation/js/app.js?mdate=1662010451"></script> <script type="text/javascript" src="https://www.nation.com.pk/assets/thenation/js/common.js?mdate=1662010451"></script> <script type="text/javascript" src="https://www.nation.com.pk/assets/thenation/js/home_page.js?mdate=1662010451"></script> <script type="text/javascript" src="https://www.nation.com.pk/assets/thenation/js/jquery.nicescroll.js?mdate=1662010451"></script> <script type="text/javascript" src="https://www.nation.com.pk/assets/thenation/js/whatsapp-button.js?mdate=1662010451"></script> <script type="text/javascript" src="https://www.nation.com.pk/assets/thenation/js/javascript_calender.js?mdate=1662010451"></script> <script type="text/javascript" src="https://www.nation.com.pk/assets/thenation/js/owl.carousel.js?mdate=1662010451"></script> <script type="text/javascript" src="https://www.nation.com.pk/assets/thenation/js/lightslider.js?mdate=1662010451"></script> <script type="text/javascript" src="https://www.nation.com.pk/assets/thenation/js/jquery.colorbox.js?mdate=1662010451"></script> <script> var $allVideos = $("iframe[src*='vimeo.com'], iframe[src*='youtube.com'], iframe[src*='dailymotion.com']"); $(window).resize(function () { $allVideos.each(function () { var $el = $(this); var parentElem = $el.parent(); var newWidth = parentElem.width(); var aspratio = 1.777; newHeight = newWidth/aspratio; $el.width(newWidth).height(newHeight); }); }).resize(); document.addEventListener("DOMContentLoaded", function(event) { var is_scoll_activated = false; if ( is_scoll_activated == false ) { window.onscroll = function() {scrollFunction()}; function scrollFunction() { if (document.body.scrollTop > 20 || document.documentElement.scrollTop > 20) { is_scoll_activated = true; var imgEl = document.getElementsByTagName('div'); for (var i=0; i<imgEl.length; i++) { if(imgEl[i].getAttribute('publishrr-src')) { console.log( imgEl[i].getAttribute('publishrr-src') ); imgEl[i].style.backgroundImage = "url('"+imgEl[i].getAttribute('publishrr-src')+"')"; } } } } } }); </script> <script> try { var arrFrames = parent.document.getElementsByTagName("IFRAME"); for (var i = 0; i < arrFrames.length; i++) { } } catch(err) { var domain_str = window.parent.location.toString(); var domain_arr = domain_str.split("/"); var domain_full_url = domain_arr[0]+"//"+domain_arr[2]+"/"; var wrapper_url = ""; if(wrapper_url != 1 ) { if ( domain_full_url != "https://www.nation.com.pk/" ) { } } } </script> <script type="text/javascript"> if ( document.referrer != '' && document.referrer.indexOf(window.location.hostname) == -1 ) { var post_data = { news_id: '844970', referrer: document.referrer, }; } else { var post_data = { news_id: '844970' }; } var url_string = window.location.href; var url = new URL(url_string); var utm_source = url.searchParams.get("utm_source"); post_data.utm_source = utm_source; $.ajax({ method: "POST", url: "https://www.nation.com.pk/ajax_post_update", data: post_data, beforeSend: function( xhr ) { } }) .done(function( data ) { }); </script> <script> recordLocalStorageNews(); insertLocalStorageNews(); function recordLocalStorageNews() { if (document.querySelector("meta[property='og:url']") == null ) { return false; } var page_title = document.querySelector("meta[property='og:title']").getAttribute("content"); var page_url = document.querySelector("meta[property='og:url']").getAttribute("content"); if (document.querySelector("meta[property='og:small_image']") != null ) { var page_image = document.querySelector("meta[property='og:small_image']").getAttribute("content"); } var page_url_arr = page_url.split('/'); if ( page_url_arr[3] == undefined || isNaN(Date.parse(page_url_arr[3])) ) { return false; } var readNewsList = Array(); var newNews = Array(); newNews[0] = Object() ; readNewsList = JSON.parse(localStorage.getItem( 'read_news_arr' )); if ( readNewsList !== null ) { newNews[0]['news_title'] = page_title; newNews[0]['news_url'] = page_url; newNews[0]['news_image'] = page_image; newNews[0]['visited_time'] = Math.round((new Date()).getTime() / 1000); let newsAlreadyExists = readNewsList.filter(data => (data.news_url == page_url )); if ( newsAlreadyExists.length > 0 ) { return false; } readNewsList.push( newNews[0] ); readNewsList = readNewsList.sort( function ( a, b ) { return b.visited_time - a.visited_time; } ); readNewsList = readNewsList.slice(0, 5); localStorage.setItem( 'read_news_arr' , JSON.stringify(readNewsList) ); } else { newNews[0]['news_title'] = page_title; newNews[0]['news_url'] = page_url; newNews[0]['news_image'] = page_image; newNews[0]['visited_time'] = Math.round((new Date()).getTime() / 1000); readNewsList = Array(); readNewsList.push( newNews[0] ); localStorage.setItem( 'read_news_arr' , JSON.stringify(readNewsList) ); } } function insertLocalStorageNews() { readNewsList = JSON.parse(localStorage.getItem( 'read_news_arr' )); var para = document.createElement("div"); para.setAttribute("id", "local_storage_news_id"); if ( readNewsList != null ) { setTimeout(function(){ readNewsList.forEach(loopNews); }, 500); } document.body.append(para); } function loopNews( item, index) { var container = document.getElementById("local_storage_news_id"); var news_html = document.createElement("a"); news_html.setAttribute("href", item.news_url); var news_img = document.createElement("img"); news_img.setAttribute('src', item.news_image); var news_label = document.createElement("p"); news_label.innerText = item.news_title; news_html.appendChild(news_img); news_html.appendChild(news_label); container.append(news_html); } var para = document.createElement("div"); para.setAttribute("id", "local_storage_news_button"); para.innerText = "History"; para.addEventListener('click', showHistory); document.body.append(para); var close_btn = document.createElement("p"); close_btn.setAttribute('id', 'close_btn'); close_btn.addEventListener('click', closeHistory); close_btn.innerText = 'Close | '; document.body.append(close_btn); var close_btn = document.createElement("p"); close_btn.setAttribute('id', 'clear_history_btn'); close_btn.addEventListener('click', clearHistory); close_btn.innerText = 'Clear History'; document.body.append(close_btn); function showHistory() { document.getElementById("local_storage_news_id").style.display = "block"; document.getElementById("close_btn").style.display = "block"; document.getElementById("clear_history_btn").style.display = "block"; document.getElementById("local_storage_news_button").style.display = "none"; } function closeHistory() { document.getElementById("local_storage_news_id").style.display = "none"; document.getElementById("close_btn").style.display = "none"; document.getElementById("clear_history_btn").style.display = "none"; document.getElementById("local_storage_news_button").style.display = "block"; } function clearHistory() { localStorage.removeItem('read_news_arr'); document.getElementById("local_storage_news_id").innerHTML = ''; } </script> <style> #local_storage_news_id { display:none; top: 0; z-index: 10000; padding-top:70px !important; width: 400px; padding: 15px; background-color: #2d2d2d; height: 100%; position: fixed !important; right: 0 !important; } #local_storage_news_id a { color: #FFF !important; display: block; float: left; margin-bottom: 30px; cursor: pointer; } #local_storage_news_id a:hover { color:#bdbcbc !important;} #local_storage_news_id img {width: 100px; float: left; width: 20%; cursor: pointer; } #local_storage_news_id p { float: right; width: 75%; color: #FFF !important; font-size: 16px; line-height: 26px; margin-top: -5px;} #local_storage_news_button { position: fixed !important; z-index: 10000; bottom: 28px; right: -28px; background-color: #e4e4e4; transform: rotate(-90deg); padding: 2px 10px 2px 10px; color: #7f7f7f; font-size: 12px; cursor: pointer; font-family: sans-serif; letter-spacing: 1px; text-transform: uppercase; font-weight: bold; } #close_btn { font-size: 15px; display:none; color: #FFF; position: fixed !important; bottom: 30px; right: 210px; z-index: 10000; cursor: pointer;direction: ltr; font-family: sans-serif !important; } #clear_history_btn { display:none; color: #FFF; position: fixed !important; bottom: 30px; right: 118px; z-index: 10000; cursor: pointer; direction: ltr; font-family: sans-serif !important; } @media only screen and (max-width: 1440px) { #local_storage_news_button { display: none; } } </style> <script type="text/javascript"> try { var arrFrames = parent.document.getElementsByTagName("IFRAME"); for (var i = 0; i < arrFrames.length; i++) { } } catch(err) { document.getElementsByTagName("html")[0].style.display="none"; document.getElementsByTagName("html")[0].innerHTML = ""; window.parent.location="https://www.nation.com.pk/"; } </script> <script type="text/javascript"> var $ = jQuery.noConflict(); </script> <script type="text/javascript"> try { if (undefined == xajax.config) xajax.config = {}; } catch (e) { xajax = {}; xajax.config = {}; }; xajax.config.requestURI = "https://www.nation.com.pk/index.php"; xajax.config.statusMessages = false; xajax.config.waitCursor = true; xajax.config.version = "xajax 0.5"; xajax.config.defaultMode = "asynchronous"; xajax.config.defaultMethod = "POST"; xajax.config.JavaScriptURI = "https://www.nation.com.pk/xajax"; </script> <script type="text/javascript" src="https://www.nation.com.pk/assets/thenation/js/xajax_core.js" charset="UTF-8"></script> <script type="text/javascript"> window.setTimeout( function() { var scriptExists = false; try { if (xajax.isLoaded) scriptExists = true; } catch (e) {} if (!scriptExists) { } }, 2000); if($('.post-sharing').html() != undefined) { $('.list-inline').find('img').css('width','27px').css('height','27px'); } </script> <script> $(document).ready(function () { $(".boxscroll").niceScroll(); $("#barnav").find('li').first().css( "background-color", "#FF0000" ); $("#barnav").find('li').first().mouseover(function(){ $(this).css("background-color", "#AD0000"); }); $("#barnav").find('li').first().mouseout(function(){ $(this).css("background-color", "#FF0000"); }); }); function event_tracking_for_blocks(block_display_name,url_link) { block_display_name = block_display_name.replace(/'/g, ""); ga('send', 'event', ""+block_display_name+"", 'click', ''+url_link+''); } $("#content-slider-block-13").lightSlider({ item:4, slideMargin:5, keyPress:true, responsive : [ { breakpoint:800, settings: { item:2, slideMove:1, slideMargin:6 } }, { breakpoint:480, settings: { item:1, slideMove:1 } } ] }); $("#content-slider-block-17").lightSlider({ item:4, slideMargin:5, keyPress:true, responsive : [ { breakpoint:800, settings: { item:2, slideMove:1, slideMargin:6 } }, { breakpoint:480, settings: { item:1, slideMove:1 } } ] }); $("#content-slider-epaper").lightSlider({ item:4, slideMargin:5, keyPress:true, responsive : [ { breakpoint:800, settings: { item:1, slideMove:1, slideMargin:6 } }, { breakpoint:480, settings: { item:2, slideMove:1 } } ] }); window.setTimeout( function() { $('#picture_gallery').trigger('click'); },50); function filter(filter_type) { if(filter_type=='picture_gallery') { $("#picture_gallery").addClass('active'); $("#snippets").removeClass('active'); $("#caption").removeClass('active'); $("#content-slider-block-10").css("display", "block"); $("#content-slider-block-10").lightSlider({ item:4, slideMargin:5, keyPress:true, responsive : [ { breakpoint:800, settings: { item:2, slideMove:1, slideMargin:6, } }, { breakpoint:480, settings: { item:1, slideMove:1 } } ] }); $("#content-slider-block-16").css("display", "none"); $("#content-slider-block-18").css("display", "none"); } else if(filter_type=='snippets') { $("#snippets").addClass('active'); $("#picture_gallery").removeClass('active'); $("#caption").removeClass('active'); $("#content-slider-block-10").lightSlider({ }); $("#content-slider-block-10").css("display", "none"); $("#content-slider-block-16").css("display", "block"); $("#content-slider-block-16").lightSlider({ item:4, slideMargin:5, keyPress:true, responsive : [ { breakpoint:800, settings: { item:2, slideMove:1, slideMargin:6, } }, { breakpoint:480, settings: { item:1, slideMove:1 } } ] }); $("#content-slider-block-18").css("display", "none"); } else if(filter_type=='caption') { $("#caption").addClass('active'); $("#snippets").removeClass('active'); $("#picture_gallery").removeClass('active'); $("#content-slider-block-16").lightSlider({ }); $("#content-slider-block-10").css("display", "none"); $("#content-slider-block-16").css("display", "none"); $("#content-slider-block-18").css("display", "block"); $("#content-slider-block-18").lightSlider({ item:4, slideMargin:5, keyPress:true, responsive : [ { breakpoint:800, settings: { item:2, slideMove:1, slideMargin:6, } }, { breakpoint:480, settings: { item:1, slideMove:1 } } ] }); } } $("#caption").click(function(){ var original = ""; if( original === ''){ original = $("#caption").text(); } $("#changetext").text(original); }); $("#picture_gallery").click(function(){ var original = ""; if( original === ''){ original = $("#picture_gallery").text(); } $("#changetext").text(original); }); $("#snippets").click(function(){ var original = ""; if( original === ''){ original = $("#snippets").text(); } $("#changetext").text(original); }); $("document").ready(function($){ $(window).scroll(function () { if ($(this).scrollTop() > 125) { $('#nav-bar').addClass("fixedd"); $('#nav-bar').find("nav").css('margin-top', '0px') } else { $('#nav-bar').removeClass("fixedd"); } }); }); $(".lightbox").colorbox({ width:"50%", height:"80%"}); if (screen.width < 768) { var cboxOptions = { width: '90%', height: '60%', maxWidth: '960px', maxHeight: '960px' }; $('.lightbox').colorbox(cboxOptions); $(window).resize(function(){ $.colorbox.resize({ width: window.innerWidth > parseInt(cboxOptions.maxWidth) ? cboxOptions.maxWidth : cboxOptions.width, height: window.innerHeight > parseInt(cboxOptions.maxHeight) ? cboxOptions.maxHeight : cboxOptions.height }); }); } </script> <script> if(typeof related_news_links !== 'undefined') { var count_paragraph = 2; $.each( related_news_links, function( key, related_news_link ){ $('.post-content').find('p').eq(count_paragraph).after(related_news_link); count_paragraph = count_paragraph + 2; }); } </script> </body> </html>